Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Getting parts for Epson 2200  (Read 3253 times)
mindful
Newbie
*
Offline Offline

Posts: 4


WWW
« on: March 19, 2006, 03:16:39 PM »
ReplyReply

I have been having problems with black ink blotches showing up on my prints, particularly B&W prints, and cleanings etc, didnt seem to help.  So I did some research and took the printer apart, cleaned the ink waste pads and the print head landing pad.  

The printer is much cleaner, but since I cleaned the landing pad, the ink cartridges seem to have lost their flow or seal or something and I have 3 cartridges with no output whatsoever.  Several cleaning cycles later, no improvement.

I thought I might try getting a new landing pad but don't know where to find parts (in Canada).   Any ideas?

Also, if you have any other ideas I might try, I'd appreciate it.
Logged
Peter McLennan
Sr. Member
****
Offline Offline

Posts: 1662


« Reply #1 on: March 19, 2006, 03:34:53 PM »
ReplyReply

You might find that waiting improves things.  Epson users commonly recommend no more than three cleaning cycles, followed by a several-hour waiting period.  Try printing again tomorrow, it might be much improved.  If not, try more cleaning cycles and wait some more.

Your cleaning approach seems good so far.

Peter
Logged
efillink
Newbie
*
Offline Offline

Posts: 15


« Reply #2 on: May 12, 2006, 02:31:05 AM »
ReplyReply

Quote
I have been having problems with black ink blotches showing up on my prints, particularly B&W prints, and cleanings etc, didnt seem to help.  So I did some research and took the printer apart, cleaned the ink waste pads and the print head landing pad. 

The printer is much cleaner, but since I cleaned the landing pad, the ink cartridges seem to have lost their flow or seal or something and I have 3 cartridges with no output whatsoever.  Several cleaning cycles later, no improvement.

I thought I might try getting a new landing pad but don't know where to find parts (in Canada).   Any ideas?

Also, if you have any other ideas I might try, I'd appreciate it.
[a href=\"index.php?act=findpost&pid=60637\"][{POST_SNAPBACK}][/a]
Logged
efillink
Newbie
*
Offline Offline

Posts: 15


« Reply #3 on: May 12, 2006, 02:31:35 AM »
ReplyReply

Quote
I have been having problems with black ink blotches showing up on my prints, particularly B&W prints, and cleanings etc, didnt seem to help.  So I did some research and took the printer apart, cleaned the ink waste pads and the print head landing pad. 

The printer is much cleaner, but since I cleaned the landing pad, the ink cartridges seem to have lost their flow or seal or something and I have 3 cartridges with no output whatsoever.  Several cleaning cycles later, no improvement.

I thought I might try getting a new landing pad but don't know where to find parts (in Canada).   Any ideas?

Also, if you have any other ideas I might try, I'd appreciate it.
[a href=\"index.php?act=findpost&pid=60637\"][{POST_SNAPBACK}][/a]

If I print with my R1800, set to Matte Heavyweight paper, I will have blotches on the paper.  If I print on glossy setting, the problem goes away.  I am using an Ink System Pro bulk ink system.  WhenI print on glossy paper, everything is fine.  Not really sure if your problem is related to the ink or the cartridge you are using.  Can you shed some light on that?

Ronnie

www.efillink.com
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad