Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: My prints look worse now they use a profile  (Read 13229 times)
AlexSingleton
Newbie
*
Offline Offline

Posts: 3


« on: June 03, 2010, 07:02:53 PM »
ReplyReply

I recently bought a ColorMunki Photo, in part because of the enthusiasm towards it by Andrew Rodney here on the LL forum, and partly because one of the journalists at Amateur Photographer in the UK reckoned it was a better choice than the Spyder Print.

Anyway, I'm sure it's a great device, but I've found myself in the hell known as colour management in Mac OS X 10.6.3 (Snow Leopard).

I have a Canon Pixma ip4700, but can't get the prints to match the screen. Now it may be that I just need to give up and get a better printer, which I plan to do as some point, but it would be nice if I could get this to work in the meantime.

I originally used ColorMunki's default ICC v4 profiles, but after reading advice on the X-Rite website and an article by Ctein, I started using ICC v2 profiles.

I think the problem may be that I cannot turn colour management off in the printer driver. I only have a choice of ColorSync (which, if selected, demands that I select a profile) or Canon Color Matching. I have selected Canon Color Matching, based on X-Rite's advice on its site (which is really for Epson printers). However, unlike with Epson drivers, there seems to be no option to set the Canon Color Matching to do nothing in a tab in the print dialogue box.

By the way, I am printing from Lightroom - although I have tried to do the workaround for printing from Photoshop (the subject of a LL article), but this doesn't seem to work either.

Any ideas, or should I just give up?
Logged
HickersonJasonC
Full Member
***
Offline Offline

Posts: 158


« Reply #1 on: June 03, 2010, 07:24:27 PM »
ReplyReply

Quote from: AlexSingleton
I think the problem may be that I cannot turn colour management off in the printer driver.

I'm no expert but this is almost definitely your problem. If you are using a printer profile in Photoshop or Lightroom AND your printer is managing color, you are applying two profiles to your print (which is no better than applying none at all).

I don't know anything about your printer. Perhaps someone here can help you figure out how to disable printer managed color for your printer.
Logged
digitaldog
Sr. Member
****
Offline Offline

Posts: 9188



WWW
« Reply #2 on: June 03, 2010, 07:44:50 PM »
ReplyReply

Quote from: AlexSingleton
By the way, I am printing from Lightroom - although I have tried to do the workaround for printing from Photoshop (the subject of a LL article), but this doesn't seem to work either.

Check out this thread on the UtoU forums for LR. There appears to be some issue with the Canon drivers.

http://forums.adobe.com/message/2681852#2681852
http://forums.adobe.com/message/2714503#2714503
Logged

Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
na goodman
Sr. Member
****
Offline Offline

Posts: 353


« Reply #3 on: June 03, 2010, 07:49:12 PM »
ReplyReply

Quote from: HickersonJasonC
I'm no expert but this is almost definitely your problem. If you are using a printer profile in Photoshop or Lightroom AND your printer is managing color, you are applying two profiles to your print (which is no better than applying none at all).

I don't know anything about your printer. Perhaps someone here can help you figure out how to disable printer managed color for your printer.

Also check this link. It is in reference to the Spyder Print but the Canon print window should look the same. http://forums.dpreview.com/forums/readflat...+color&qf=m
« Last Edit: June 04, 2010, 07:01:24 AM by na goodman » Logged
ChasP505
Full Member
***
Offline Offline

Posts: 114



« Reply #4 on: June 03, 2010, 09:48:09 PM »
ReplyReply

In the printer settings, turn off print preview.
Logged

Chas P.
pherold
Full Member
***
Offline Offline

Posts: 133


« Reply #5 on: June 04, 2010, 12:29:01 PM »
ReplyReply

We have had good luck with the work around  na goodman mentioned in the dpreview link:
http://forums.dpreview.com/forums/readflat...+color&qf=m  

Except that we have found you need to use "sRGB" as the critical profile when on Snow Leopard, and "genericRGB" as the profile to use when in Leopard.
Logged

-Patrick Herold
  Tech Support
www.chromix.com
Simon J.A. Simpson
Full Member
***
Offline Offline

Posts: 187


« Reply #6 on: June 04, 2010, 04:48:35 PM »
ReplyReply

Quote from: AlexSingleton
I recently bought a ColorMunki Photo, in part because of the enthusiasm towards it by Andrew Rodney here on the LL forum, and partly because one of the journalists at Amateur Photographer in the UK reckoned it was a better choice than the Spyder Print.

Anyway, I'm sure it's a great device, but I've found myself in the hell known as colour management in Mac OS X 10.6.3 (Snow Leopard).

I have a Canon Pixma ip4700, but can't get the prints to match the screen. Now it may be that I just need to give up and get a better printer, which I plan to do as some point, but it would be nice if I could get this to work in the meantime.

I originally used ColorMunki's default ICC v4 profiles, but after reading advice on the X-Rite website and an article by Ctein, I started using ICC v2 profiles.

I think the problem may be that I cannot turn colour management off in the printer driver. I only have a choice of ColorSync (which, if selected, demands that I select a profile) or Canon Color Matching. I have selected Canon Color Matching, based on X-Rite's advice on its site (which is really for Epson printers). However, unlike with Epson drivers, there seems to be no option to set the Canon Color Matching to do nothing in a tab in the print dialogue box.

By the way, I am printing from Lightroom - although I have tried to do the workaround for printing from Photoshop (the subject of a LL article), but this doesn't seem to work either.

Any ideas, or should I just give up?

Hi Alex.

You definitely should not give up !

As luck has it I have the hardware and configuration that you have (with the exception of Lightroom).  I have profiled my iP4700 using the ColorMunki and have got good results.  What we need to do is to try and eliminate, one by one, what might be causing the problem.  With Colour Management there are many complexities, and many things that can be inadvertently incorrectly set, resulting in prints which do not match your display.  You will need a lot of patience, and to take a careful and methodical approach - with both of these you will ultimately be successful.

Let's take the quick and easy approach first and perhaps we might be hit on the problem and be able to solve it !
(please excuse me if I am attempting to 'teach my grandmother to suck eggs' – i.e. you already know, or have already done, some of my suggestions already).

First things first.  Have you profiled your display using the ColorMunki ?  This is what you must do first and foremost.

I note that you say that you seem unable to turn-off colour management in your printer driver so perhaps we can start here.  As I do not have Lightroom, can you use Photoshop ?  Can you tell me which version of Photoshop you are using ?

If the printer dialogue is giving you a choice of 'ColorSync' or 'Canon Color Matching' then it sounds as if you have not configured the Photoshop  or Lightroom print dialogue correctly (I am not familiar with Lightroom so I can only speak with authority about PS).  In the Photoshop print dialogue you need to ensure that your choose 'Photoshop Manages Colors' under 'Color Handling:' and then select the correct profile under 'Printer Profile:' and 'Perceptual' or 'Relative Colormetric' under 'Rendering Intent:'.  In Photoshop CS4 (and possibly CS3) colour management in the printer is then 'automatically' 'turned-off'† - no matter what any of the greyed-out menus say.
† strictly speaking it's not 'turned-off', apparently, but works as if it is (a subject of other long a tortuous postings)

In Photoshop CS4/5 and Snow Leopard you cannot turn on or off Colour Management (this is done 'automatically' for you) but you need to make sure that you are using the correct driver settings to get the best results.  When you enter the printer's dialogue box you need to ensure that under 'Quality & Media' you select 'Photo Paper Pro II'* as the 'Media Type' and select 'Print Quality: Custom'; move the 'Quality:' slider far over to the right.  Before you go any further Save these settings as "iP4700 Colour Managed" under 'Presets:'.  Always use these settings when printing ColorMunki targets for profiling and when printing colour managed images.
* The reason you use 'Photo Paper Pro II' as the media type is that this will give you, potentially, the best possible quality on any paper (I was told this by Canon UK).

You are right to use the ICC version 2 profiles.

I hope this my help.  If not post again and I'll see what I can do to assist.

Simon
« Last Edit: June 04, 2010, 04:52:22 PM by SimonS » Logged
AlexSingleton
Newbie
*
Offline Offline

Posts: 3


« Reply #7 on: June 05, 2010, 04:40:42 AM »
ReplyReply

Quote from: na goodman
Also check this link. It is in reference to the Spyder Print but the Canon print window should look the same. http://forums.dpreview.com/forums/readflat...+color&qf=m

Thank you so much (to everyone here) for your advice. After selecting ColorSync and Generic RGB in the print dialogue box, I was able to print successful test sheets and I now have wonderful prints, accurately representing what's on my screen.
Logged
sanvandur
Jr. Member
**
Offline Offline

Posts: 65


WWW
« Reply #8 on: August 24, 2010, 01:58:36 PM »
ReplyReply

What makes the V2 profiles better?
Logged

digitaldog
Sr. Member
****
Offline Offline

Posts: 9188



WWW
« Reply #9 on: August 29, 2010, 12:15:12 AM »
ReplyReply

What makes the V2 profiles better?

They are not better, but they are more compatible with more software products.
Logged

Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
AndyF
Newbie
*
Offline Offline

Posts: 44


WWW
« Reply #10 on: August 29, 2010, 08:18:14 PM »
ReplyReply

In the printer settings, turn off print preview.
That sounds odd; have you found that print preview affects the print itself?  I'd agree the preview of the print is mostly useful just for judging where it will be placed on the paper and not for colour accuracy.
-Andy
Logged
ChasP505
Full Member
***
Offline Offline

Posts: 114



« Reply #11 on: August 30, 2010, 06:56:14 PM »
ReplyReply

That sounds odd; have you found that print preview affects the print itself? 

It was identified as an issue with these printers on another forum site, but I don't currently have a link to the source.

You've got nothing to lose by trying it...  Simply uncheck "Preview Before Printing" in the printer settings.
Logged

Chas P.
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad