Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Which Software Can I use On MAC G5 OSX 10.4  (Read 3563 times)
rollsman44
Jr. Member
**
Offline Offline

Posts: 60


« on: December 01, 2011, 02:34:34 PM »
ReplyReply

I have a Mac G5 OSX 10.4 and cant seem to find many or very few Post Proc.software to use with my NEWLY acquired Mamiya 645AFD11 and Leaf Aptus 22 back. Its an older OS and want to do some PP work on my images. Most softwares require Intel or a Higher # OSX 10.5 and higher. Any ideas that can assist me ?  I do very LITTLE work as I am Retired and now do some Portraits and family shots. I have been shooting weddings for over 38 years now. Just a hobby now. Thank you,  rollsman
Logged
deejjjaaaa
Sr. Member
****
Offline Offline

Posts: 743


« Reply #1 on: December 01, 2011, 04:37:35 PM »
ReplyReply

I have a Mac G5 OSX 10.4 and cant seem to find many or very few Post Proc.software to use with my NEWLY acquired Mamiya 645AFD11 and Leaf Aptus 22 back. Its an older OS and want to do some PP work on my images. Most softwares require Intel or a Higher # OSX 10.5 and higher. Any ideas that can assist me ?  I do very LITTLE work as I am Retired and now do some Portraits and family shots. I have been shooting weddings for over 38 years now. Just a hobby now. Thank you,  rollsman

I guess you saw the answers about the raw converters in your prev. 2 topics, as for the PP'ing :

photoline = http://www.pl32.com/pages/down.php

cheap, small, Mac OS X 10.4/10.5/10.6/10.7, 512 MB Ram, 50 MB harddisk space, can work on 1024x600 screen resolution, 32- and 64-Bit version in package

PS: or you can try to find an older version of PixelMator... the current one it seems requires a more modern HW/OSX than you have.
« Last Edit: December 01, 2011, 04:41:23 PM by deejjjaaaa » Logged
Michael H. Cothran
Full Member
***
Offline Offline

Posts: 136



« Reply #2 on: February 22, 2012, 09:19:18 AM »
ReplyReply

PS CS3 will run on 10.4, as well as whatever version of ACR and Bridge that was bundled with it.
Logged
langier
Sr. Member
****
Offline Offline

Posts: 617



WWW
« Reply #3 on: February 22, 2012, 11:00:27 AM »
ReplyReply

I run PS CS-4 on my G5 dual and still run my 9800 on the platform.

If you need to open a raw file on from a newer camera than your version of Photoshop supports, you can probably run it though the DNG converter to make it backward compatible.

Since PS CS-5 has to be "dumbed-down" to run the Portrait Packages and Contact Sheet II, I still keep CS-4 going for this very reason. It's a PIA to do contact sheets through Bridge or have to shut-down CS-5, set to 32-bit and reopen only to have to repeat the process once you are done. Both those are such time savers and worked well that I'm surprised they haven't been updated to 64-bit.
Logged

Larry Angier
ASMP, NAPP, ACT, and many more!

Webmaster, RANGE magazine
Editor emeritus, NorCal Quarterly

web--http://www.angier-fox.photoshelter.com
facebook--larry.angier
twitter--#larryangier
google+LarryAngier
Chairman Bill
Sr. Member
****
Offline Offline

Posts: 1439


« Reply #4 on: February 22, 2012, 01:52:53 PM »
ReplyReply

I have a copy of the original Aperture (v.1) which ran on PowerMacs. Do you by any chance live in the UK?
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad