Ad
Ad
Ad
Pages: « 1 [2]   Bottom of Page
Print
Author Topic: New video on website: Feedback appreciated!  (Read 2528 times)
smthopr
Full Member
***
Offline Offline

Posts: 206


WWW
« Reply #20 on: April 13, 2012, 05:43:33 PM »
ReplyReply

Thanks Michael,

Macs were traditionally gamma 1.8 until recently. Now they come set to gamma 2.2 I think. To make it more complicated, the newer qt players check for the gamma setting of the monitor and make an adjustment, unless it's set in the preferences to "display for dcp compatibility" in which case, no correction is made. Fcp doesn't adjust (at least not the fcp7) and require that the monitor be set to gamma 1.8. iPads and phones play back at gamma 2.2 so it's really unpredictable!

Fred,
I'll try out your code when I figure out how to implement it Smiley
Logged

Bruce Alan Greene
www.brucealangreene.com
smthopr
Full Member
***
Offline Offline

Posts: 206


WWW
« Reply #21 on: April 13, 2012, 08:30:33 PM »
ReplyReply

Fred,
Tried your code, but the page didn't quite display correctly for me.

I did add "</embed>" to my code.  Let me know if this helps. Or makes things worse Huh
Logged

Bruce Alan Greene
www.brucealangreene.com
fredjeang
Guest
« Reply #22 on: April 14, 2012, 03:10:19 AM »
ReplyReply

Ok, more news.

About the code, you have to close the embed anyway. It can not stay open, it's a code error.
It's correct to add "</embed>"  to close an open one.
Something is happening because the source code doesn't change on windows. It seems that you are doing html changes that aren't taken into consideration but only in MNac.
I've checked in different Windows units, with all possible browsers, emptying cachés etc...


But I've discovered something interesting:

I've downloaded your video. Sound plays perfect as I told you before, but... on older QT versions in Windows, not with the latest. If I open your QT video with
old QT or other players, it works. If I use the latest QT updated in Windows, it does not have the sound.

This afternoon, as I got one copy, I'll put your video in our server with my code so we can check what happens. I really hope it's going to work. 
Logged
fredjeang
Guest
« Reply #23 on: April 14, 2012, 06:31:54 AM »
ReplyReply

SOLVED !

I tell you what happened.

I realized, doing a quick research in internet, that I was far from being the only one who had suddenly no more sound with QT files when played in QT 7.#. In fact a lot of people experienced it, even in Mac.
So I did an inquiery.

The issue came from a bad implemented auto-up-date. I had to manually re-install the QT player from the Apple page and choose "repair". That explains why on older windows I didn't have issues because this Apple updated wasn't installed yet.

Now it works ! Yeah. Happy end.  

However...this is a really bad annoying situation because there must be millions of users (no, there are actually) with this issue without them to even notice it (because the .mov files are viewed perfectly in other viewers). When they want to play the .mov in internet, it would be silent and I'm not sure most of the people will even find the time to check what was involved.
This is not trustable as a professional viewer unless you show yourself the work in a device you know it's working. Otherwise there will be always this doubt that it might not be played properly.

Honestly, it doesn't give a lot of confidence to use the QT player. Thank god we switched to html5 before this Apple hassle. (the sound in QT is prob for commercial reasons).

So if Apple wants people to use this player in other platforms, they need to stop hassleling like that and being serious, included the gamma shift. It reminds me Windows 10 years ago.

The good news is that its working. The bad news is that it's working because I had to repair the QT update. (reminds me of a RCX update).

At least we end to know what was happening. But Bruce, as soon as you can, change all that and get rid of the QT. Not reliable enough to display professionaly.

Ps: and, oh yeah, close this embed tag in the code. Wink
« Last Edit: April 14, 2012, 06:41:25 AM by fredjeang » Logged
fredjeang
Guest
« Reply #24 on: April 14, 2012, 10:30:24 AM »
ReplyReply

Bruce,

I had 20min to loose this afternoon. I uploaded your video in our server but using html 5.

So what you see here: http://www.pepe-botella.com/BRUCE/test-bruce.html

is actually html 5.

Let me know if it works on your computer and mobile devices. I am not expert, so it might not work, I've just been playing. (on all my computer units and phones it works)

look how simple is the code:



<!DOCTYPE html>
<html>
<head>
<title>test-bruce</title>

<link href="video-js.css" rel="stylesheet" type="text/css">

<script src="video.js"></script>

</head>

<body>

<video id="example_video_1" class="video-js vjs-default-skin"  controls preload="none" width="760" height="330"
      poster="bruce.png"
      data-setup="{}">
    <source src="8fd_4min760x330.mp4" type='video/mp4'>
   <source type='video/webm' src="8fd_4min760x330.webmvp8.webm">
</video>


</body>
</html>


--------------
It's very easy to do.

you just have to replace (re-write) the extension .bloody naughty mov by .mp4
then put 4 files I can send to you if you're interested.

I've also done a second version in webM to secure the compatibility. It's very easy to do and understand. Our gran'ma could do it.

please let me know if you can view it properly.

Then I will erase it from our server after you checked it.



« Last Edit: April 14, 2012, 10:33:09 AM by fredjeang » Logged
smthopr
Full Member
***
Offline Offline

Posts: 206


WWW
« Reply #25 on: April 14, 2012, 11:38:27 AM »
ReplyReply

Hi Fred,

Ah, good news.  and not so good news about the QT Player fiasco.

About the </embed>, i did add it.  Here's is from my Safari browser of the code downloaded from my server.  What is interesting to me is that the "<embed"  doesn't have a closed ">"

I think the "</embed>" I added is doing nothing....


"   <param name="scale" value="1">
                  <param name="bgcolor" value="#696969">
                  <param name="src" value="original%20art%20folder/8fd_4min760x330.mov">
                  <param name="autoplay" value="true">
                  <param name="controller" value="true">
                  <embed height="359" pluginspage="http://www.apple.com/quicktime/download/" src="original%20art%20folder/8fd_4min760x330.mov" type="video/quicktime" width="772" controller="true" autoplay="true" bgcolor="#696969" scale="1">
               </object></embed></td>"

The page you made plays in Safari, albeit, it plays jerky until enough is downloaded.  But I do need to get the video into my page graphics.

Thanks so much for all your research!
Logged

Bruce Alan Greene
www.brucealangreene.com
fredjeang
Guest
« Reply #26 on: April 14, 2012, 11:57:26 AM »
ReplyReply

Bruce,

Correct, the embed you added is doing "apparently" nothing but in fact it will avoid possible problems. It was a missing tag. Browsers normally have a sort of tolerance when the code is uncomplete, but it depends. As I pointed, Safari is never used by devs as a base browser because it's problematic. So this tag, although not at first relevant is necesary.

As Cooter likes to say, it's the wild west!

I'm not surprised in the end that people Like Recuenco just embed in Vimeo to avoid compatibility hassles.

There is a Vimeo equivalent but with higher quality call Exposureroom. Lots of filmakers are there. It's more pro-orientated that I've heard.

Best regards and have a nice week-end.  

Ps: using the html 5 code on your page, here: http://www.pepe-botella.com/BRUCE/test-bruce2.html. (you'd need 4 files to make the html 5 works, if you want them mail me I send it to you)
Here would be the complete code:


<!DOCTYPE html>

<html>

   <head>

      <title>8 First Dates sampler</title>

<link href="video-js.css" rel="stylesheet" type="text/css">

<script src="video.js"></script>
  
</head>

   <body bgcolor="#ffffff">
      <table width="1920" border="0" cellspacing="0" cellpadding="0" bgcolor="#222222" background="original%20art%20folder/generic%20bg%204.png" cool gridx="16" gridy="16" height="1280" showgridx showgridy>
         <tr height="112">
            <td width="1919" height="112" colspan="7"><spacer type="block" width="1919" height="112"></td>
            <td width="1" height="112"><spacer type="block" width="1" height="112"></td>
         </tr>
         <tr height="368">
            <td width="32" height="368"><spacer type="block" width="32" height="368"></td>
            <td width="1887" height="368" colspan="6" valign="top" align="left" xpos="32">

<video id="example_video_1" class="video-js vjs-default-skin"  controls preload="none" width="760" height="330"
      poster="bruce.png"
      data-setup="{}">
    <source src="8fd_4min760x330.mp4" type='video/mp4'>
   <source type='video/webm' src="8fd_4min760x330.webmvp8.webm">
</video>

              </td>
            
<td width="1" height="368"><spacer type="block" width="1" height="368"></td>
         </tr>
         <tr height="106">
            <td width="48" height="106" colspan="2"><spacer type="block" width="48" height="106"></td>
            <td content csheight="61" width="752" height="106" colspan="4" valign="top" xpos="48"><font size="+1" color="#e8e8e8">Sampler from the Russian romantic comedy &quot;8 First Dates&quot; </font>
               <p><font size="+1" color="#e8e8e8">Directed by: David Dodson, Sasha Malarevsky</font></p>
            </td>
            <td width="1119" height="106"><spacer type="block" width="1119" height="106"></td>
            <td width="1" height="106"><spacer type="block" width="1" height="106"></td>
         </tr>
         <tr height="44">
            <td width="50" height="44" colspan="3"><spacer type="block" width="50" height="44"></td>
            <td content csheight="33" width="749" height="44" colspan="2" valign="top" xpos="50"><font size="+1" color="#e8e8e8"><a href="http://vimeo.com/32825688">can't view the quicktime? see it on Vimeo, password &quot;bruce&quot;</a></font></td>
            <td width="1120" height="44" colspan="2"><spacer type="block" width="1120" height="44"></td>
            <td width="1" height="44"><spacer type="block" width="1" height="44"></td>
         </tr>
         <tr height="649">
            <td width="48" height="649" colspan="2"><spacer type="block" width="48" height="649"></td>
            <td content csheight="21" width="288" height="649" colspan="2" valign="top" xpos="48"><font face="Helvetica, Geneva, Arial, SunSans-Regular, sans-serif"><font size="4" color="#474747"><u><a href="index.html"><strong><em>return to home page</em></strong></a></u></font></font></td>
            <td width="1583" height="649" colspan="3"><spacer type="block" width="1583" height="649"></td>
            <td width="1" height="649"><spacer type="block" width="1" height="649"></td>
         </tr>
         <tr height="1" cntrlrow>
            <td width="32" height="1"><spacer type="block" width="32" height="1"></td>
            <td width="16" height="1"><spacer type="block" width="16" height="1"></td>
            <td width="2" height="1"><spacer type="block" width="2" height="1"></td>
            <td width="286" height="1"><spacer type="block" width="286" height="1"></td>
            <td width="463" height="1"><spacer type="block" width="463" height="1"></td>
            <td width="1" height="1"><spacer type="block" width="1" height="1"></td>
            <td width="1119" height="1"><spacer type="block" width="1119" height="1"></td>
            <td width="1" height="1"><spacer type="block" width="1" height="1"></td>
         </tr>
      </table>
      <p></p>
   </body>

</html>


 



« Last Edit: April 14, 2012, 02:19:09 PM by fredjeang » Logged
mmurph
Sr. Member
****
Offline Offline

Posts: 507


WWW
« Reply #27 on: April 14, 2012, 06:14:26 PM »
ReplyReply

Fred's version (html5) played on my iPhone with no problem!

Same on laptop. Quicktime there is version 7.7.1, which I think is current. 64 bit Windows Explorer.

Also worked in Safari and Chrome on the Windows 7 laptop.

Sound starts out high, I have to reach for volume in each. Could you ramp the sound a bit over the first few seconds (in your export, not HTML) to give folks a chance to adjust?

Congrats on the project!

Michael
« Last Edit: April 14, 2012, 11:17:15 PM by mmurph » Logged
Pages: « 1 [2]   Top of Page
Print
Jump to:  

Ad
Ad
Ad