Ad
Ad
Ad
Pages: [1] 2 »   Bottom of Page
Print
Author Topic: Weird behaviour with the crop or straighten tool in PS6  (Read 10441 times)
Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« on: May 31, 2012, 07:20:21 AM »
ReplyReply

I apologise if this topic has been covered elsewhere, and wonder if anyone else has encountered the following problem.

Make a new file in PS6 (RGB mode). Fill it with 100% black. Use the Crop tool and rotate to taste. Press Enter to accept the crop and zoom in to enjoy the black and grey noise patterning reminiscent of a man's suit. The Straighten tool will achieve the same result. Your suit pattern will vary according to the degree of rotation.

I thought initially that this was PS playing havoc with shadow areas of my photographs when I rotated them, but when in the interests of science I used the above procedure for the sake of comparison, I found what may be a more general problem.

Not replicable in Greyscale mode, as far as I can tell.

I'm using a Mac Pro with OS10.6.8.
Logged
Schewe
Sr. Member
****
Offline Offline

Posts: 5489


WWW
« Reply #1 on: May 31, 2012, 08:48:14 AM »
ReplyReply

Let me guess...you are zooming way in and you have Pixel Grid turned on as an option in the show options of the View menu?
Logged
Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #2 on: May 31, 2012, 09:14:08 AM »
ReplyReply

Thanks for your reply, Jeff.

Unfortunately, the patterning is visible at 100% zoom and is independent of whether I have the View>Show>Pixel Grid checked or not.

Stranger still, the patterning disappears if I convert the file from 16 to 8 bit.
Logged
Schewe
Sr. Member
****
Offline Offline

Posts: 5489


WWW
« Reply #3 on: May 31, 2012, 12:52:29 PM »
ReplyReply

Well, it must be you. I can't duplicate it...
Logged
artobest
Sr. Member
****
Offline Offline

Posts: 261


WWW
« Reply #4 on: May 31, 2012, 03:08:20 PM »
ReplyReply

I can. It happened to me today for the first time. I put it aside to deal with later, as I was already up to my ears trying to sort out the Disappearing Drop-down Menus in Curves Layers After Using Crop Tool bug.
Logged

Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #5 on: June 01, 2012, 04:53:56 AM »
ReplyReply

A little more information:

Converting the 16-bit file to 8-bit will remove the patterning, as will converting the file to another mode (Greyscale, Lab, CMYK).

If I create a new layer that duplicates the rotated layer, the patterning disappears (unless you reduce Opacity).

Saving the 16-bit file as a TIFF or .psd will preserve the patterning. Saving it as a JPEG will remove it.

The patterning is not camera-make-dependent: I can replicate the effect with both Canon and Hasselblad files.





Logged
AFairley
Sr. Member
****
Offline Offline

Posts: 1165



« Reply #6 on: June 01, 2012, 11:06:50 AM »
ReplyReply

I can't duplicate (CS6 32 bit, 5x7" 360 dpi new doc w. white background, fill with black, straighten @ 40 degrees & accept, zoom in from 100% to max), same with 8-bit and 16-bit file.
Logged

Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #7 on: June 01, 2012, 11:34:09 AM »
ReplyReply

For me, the effect is only obtainable with rotation of 16-bit files. If I start with a new 5x7" 32-bit file at 360 ppi and RGB, then rotate and accept, and then convert to 16-bit, there is no patterning. But if I convert my 32-bit file to 16-bit, and then rotate, I get the same old patterned noise.

As I like to work with lots of shadow in 16-bit, this is a bit of a nuisance. I have not yet made a print to see if the gentlemen's suit patterns reproduce on paper.

Logged
Pete_G
Full Member
***
Offline Offline

Posts: 233


WWW
« Reply #8 on: June 03, 2012, 02:55:03 AM »
ReplyReply

I can reproduce this. With a 16 bit file I get the pattern, with an 8 bit file I don't.
Logged

___________________
http://www.petergoddard.org
kaelaria
Sr. Member
****
Offline Offline

Posts: 2228



WWW
« Reply #9 on: June 03, 2012, 11:15:33 PM »
ReplyReply

All I get is the pixel grid pattern when zooming far enough, for me that' 500%.
Logged

Pete_G
Full Member
***
Offline Offline

Posts: 233


WWW
« Reply #10 on: June 04, 2012, 03:43:54 AM »
ReplyReply

This is some kind of issue with the video card I imagine. I get the pattern on my Thinkpad laptop but not on my desktop. A patterned file made on my laptop exhibits normally on the desktop machine or even in CS5 on the laptop. It only seems to be the crop tool rotation too, Image>Image Rotation>Arbitrary does not cause a pattern. Both systems are 64 bit.
Logged

___________________
http://www.petergoddard.org
Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #11 on: June 04, 2012, 04:33:44 AM »
ReplyReply

Problem 'explained'!!! Yes, the video card is indeed implicated.

Go to Preferences>Performance. If under Detected Graphics Processor, you have checked Use Graphics Processor, then the 16-bit file crop/rotation weirdness will occur as described above. If you leave it unchecked, then restart PS6, the gentlemen's suit patterns will no longer appear upon cropping/rotating.
Logged
kaelaria
Sr. Member
****
Offline Offline

Posts: 2228



WWW
« Reply #12 on: June 04, 2012, 10:08:02 AM »
ReplyReply

Mine's been checked since I installed it.

Nvidia 560ti card, custom PC.
Logged

Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #13 on: June 04, 2012, 10:10:07 AM »
ReplyReply

Mine's an ATI Radeon HD 4870 on a MacPro (early 2009 variety).
Logged
artobest
Sr. Member
****
Offline Offline

Posts: 261


WWW
« Reply #14 on: June 05, 2012, 06:40:32 AM »
ReplyReply

Mine's an ATI Radeon HD 5800 and I get the patterns - so it looks like an ATI issue?
Logged

Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #15 on: June 05, 2012, 06:48:21 AM »
ReplyReply

Hmmm ..... I've also posted this 'problem' on the Adobe Photoshop forum, and it has received the attention of an Adobe representative. We'll see!
Logged
Pete_G
Full Member
***
Offline Offline

Posts: 233


WWW
« Reply #16 on: June 05, 2012, 09:17:36 AM »
ReplyReply

It's not an ATI issue, I have the problem with my Thinkpad laptop and that's got an Nvidia 570M in it. I installed the latest driver, since the original one was quite old, and that reduced the effect but did not remove it.
Logged

___________________
http://www.petergoddard.org
artobest
Sr. Member
****
Offline Offline

Posts: 261


WWW
« Reply #17 on: June 25, 2012, 08:19:09 AM »
ReplyReply

Has anybody found a workaround yet for this intensely irritating bug?
Logged

Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #18 on: June 25, 2012, 08:37:16 AM »
ReplyReply

Adobe know about it, but I've heard nothing further.
Logged
Eric Kellerman
Jr. Member
**
Offline Offline

Posts: 89



WWW
« Reply #19 on: June 26, 2012, 03:13:44 AM »
ReplyReply

Adobe now say they cannot replicate the problem, but that it might have to do with the video card. Another contributor asked me to post full system details via PS>Help>System Info. I have done this, but of course I am not the only person with this problem, so it might be useful if others afflicted by this annoyance chime in on the Adobe forum too.

For an example of the patterning, download the psd file (1mb) at http://www.erickellermanphotography.com/pattern.psd
« Last Edit: June 26, 2012, 07:54:48 AM by Eric Kellerman » Logged
Pages: [1] 2 »   Top of Page
Print
Jump to:  

Ad
Ad
Ad