Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Solution for PSCS6 hanging up saving big .psb's?  (Read 840 times)
bill t.
Sr. Member
****
Offline Offline

Posts: 2693


WWW
« on: February 18, 2013, 09:44:51 PM »
ReplyReply

Would like to hear from somebody who has actually solved the following problem.  There are plenty of unresolved threads on the net about this.

When trying to save a psb file that is 7.3GB on the disc, PSCS6 seems to hang up at the "Saving 0%" phase, while actually doing nothing for as much as 2 hours straight.

If I try to quit CS6, I get a "Save in Progress" dialogue.  No "X" or "Cancel" buttons are available.  There is not the customary "X" in the "Saving" bar down at lower left.  So the software must be dreaming the impossible dream somewhere in the first few lines of the file saving code, before the "X" is displayed.

Everything else seems to work OK, but that "0%" never changes and the file never saves and no option to abort the operation is ever offered.  Have looked around for covered-up dialogues, nothing is there.  No other programs are running, except Chrome.

At this point I would be happy to just abort the save without damaging the presumably open file, and move on.

So are there are any "secret keystrokes" or any other way to safely cancel the save?  "Esc" is ignored.  I'm willing to lose the 2 hours of work invested in the latest edits, but would rather not trash the existing file.

Win 7, 24gb, 17.7 used, 6.4 available.  Gobs of space on all the scratch discs.  Totally steady system in every way.

OK, I just duplicated the image, flattened it, and saved it as a copy.  That worked!  But the layered version is still "Saving 0%".  And I can even "Place" the saved, flattened version over the hapless, hung-up layered version.  So I bet there are undocumented file size limitations lurking somewhere, wish I knew what they were.
Logged
Schewe
Sr. Member
****
Offline Offline

Posts: 5427


WWW
« Reply #1 on: February 18, 2013, 11:09:43 PM »
ReplyReply

So I bet there are undocumented file size limitations lurking somewhere, wish I knew what they were.

The only PSB file limitations are 300K x 300K. But I don't think it's a question of PSBs being slow when saving...I think it's the Save in the background that is causing your slowness. In the CS6 Prefs under File Handling do you have the Save in Background turned on? Also under File Compatibility do you have Disable Compression of PSD & PSB files turned on?

What I think you are seeing (although 2 hrs seems way excessive) is that saving in the background is a background process that cuts the cpu cycles to allow further work and means saving is no longer "modal". This can be a good thing but it can also have consequences–it takes more time to start and execute a save.

For myself, I've found that the downsides of Save in Background outweigh the upsides and I really started hating the Auto Save. I'm not saying YOU should turn it off, but it's something you might want to test. Also, the compression for PSD & PSB files also takes extra cpu clicks–another factor in slowing saves down.
Logged
bill t.
Sr. Member
****
Offline Offline

Posts: 2693


WWW
« Reply #2 on: February 18, 2013, 11:53:22 PM »
ReplyReply

Thanks Jeff, that was very helpful.  After a forced closing of PS, I was able to recover about 1/3 of my last session through an automatic recovery.  With the background save unchecked and compression turned off, the file now saves in about 4 minutes.

With huge chunks of core memory already committed, I never really did anything with PS during the background saves, anyway.  And while the save operation is now modal relative to PS, I can still fiddle around on the web or in other apps.

When the file was about 1gb smaller, the background saves were already starting to take quite a long time.  I must have hit a file size where disc caching or some other memory-strapped tactic was starting to cut in.  I had dreamed that 24gb might be "enough."  Now I wish I had gone for 48.

Maybe I need to read the manual someday.
Logged
Schewe
Sr. Member
****
Offline Offline

Posts: 5427


WWW
« Reply #3 on: February 18, 2013, 11:58:14 PM »
ReplyReply

With the background save unchecked and compression turned off, the file now saves in about 4 minutes.

Just be sure you understand the implications...unchecking Save in Background will dim (disable) Auto Save. So, if you crash while working or saving, there is no recourse...your file will be toast.

I just got to the point where I wasn't seeing the benefit in Save in Background because I work on either really large (or often small) files. The save times on the really large files was driving me nutz. So I turned it off...knowing full well the full implications.

BTW, 32 gigs + is useful if you are working on really large images...that's what I have in my main workstation.
« Last Edit: February 18, 2013, 11:59:50 PM by Schewe » Logged
bill t.
Sr. Member
****
Offline Offline

Posts: 2693


WWW
« Reply #4 on: February 19, 2013, 12:20:53 AM »
ReplyReply

Just be sure you understand the implications...unchecking Save in Background will dim (disable) Auto Save. So, if you crash while working or saving, there is no recourse...your file will be toast.

Well somehow I had managed to survive every previous edition of PS simply by developing good, frequent saving and revision increment habits, so I'll just have to plug those back into my brain sockets.

But it is kinda insidious the way that if you uncheck "Save in Background", the Auto Save box also automatically unchecks itself more or less hidden by the mouse cursor.  I didn't even notice that happened a few minutes ago, thanks for pointing it out.
Logged
Schewe
Sr. Member
****
Offline Offline

Posts: 5427


WWW
« Reply #5 on: February 19, 2013, 01:39:06 AM »
ReplyReply

But it is kinda insidious the way that if you uncheck "Save in Background", the Auto Save box also automatically unchecks itself more or less hidden by the mouse cursor.

They are connected...disable Save in Background and Auto Save is disabled.
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad