Ad
Ad
Ad
Pages: « 1 [2]   Bottom of Page
Print
Author Topic: Leaf Aptus 75 still unreliable after repair, help please  (Read 3281 times)
Raul_82
Full Member
***
Offline Offline

Posts: 113


WWW
« Reply #20 on: September 02, 2013, 11:46:20 PM »
ReplyReply

As a Leaf owner I have read your other threads on this matter. I can understand your frustration.

I think it is time to realize that maybe Leaf backs are just not that reliable. I've learn to deal with mine after a replacement (of a brand new back) and then a repair on the replacement. I used to live with fear that it would brake again after the warranty expires, altought i guess the last time they make it right because the back as been performing flawless ever since, i think it has been about a year now! Knock wood (toc, toc)  Grin

Of course, no long exposures for this baby at night, at least not in the permanent Florida summer, which is where I live now, but night photography is not my thing anyway. I do have a pending test for a long exposure shot in cooler latitudes to see what happens, i'm hoping for usable files once the back doesn't get so hot. But the performance in the studio is good (i shoot thetered most of the time) an I even use the back/645df for family & friends shots and, men, i love those negatives.

In the meantime I'm saving for a future Fuji X-Pro1 (or x-pro2 maybe) which i think is all I need for anything that is not meant to be printed big.

Good luck!

Raul
Logged
torger
Sr. Member
****
Offline Offline

Posts: 1590


« Reply #21 on: September 03, 2013, 02:12:15 AM »
ReplyReply

Thanks. The problem has now been resolved, see the thread: http://www.luminous-landscape.com/forum/index.php?topic=81389.0
Logged
Pages: « 1 [2]   Top of Page
Print
Jump to:  

Ad
Ad
Ad