Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Just upgraded firmware on 5DIII  (Read 724 times)
walter.sk
Sr. Member
****
Offline Offline

Posts: 1322


« on: April 30, 2013, 05:00:28 PM »
ReplyReply

Got email from Canon with link to the 5DIII firmware 1.2.1, downloaded it, unzipped it, copied the file to the root directory of my CF card and followed the instructions in the accompanying PDF.  All seems to have gone well, and now I can use my 500mm f/4 with a Canon 2X extender and still autofocus.  I'm a happy camper!
Logged
jrsforums
Sr. Member
****
Offline Offline

Posts: 705


« Reply #1 on: April 30, 2013, 05:24:17 PM »
ReplyReply

FYI...here is all the firmware addresses...

http://www.usa.canon.com/cusa/support/consumer/eos_slr_camera_systems/eos_digital_slr_cameras?pageKeyCode=prdAdvDetail&docId=0901e02480899dff
Logged

John
SangRaal
Jr. Member
**
Offline Offline

Posts: 71


« Reply #2 on: May 02, 2013, 09:27:40 AM »
ReplyReply

Well It's up and running in the camera; I wondered when I was going through the fix list why i really need to put this up(fix Arabic menu +++) until i got to the change ISO glitch, a bug that has bitten me several times so It became worthwhile to to update (It's not like going to V 2.xxx on the 7D). I never got the telephoto + telextender glitch because all this winter When I shot ski racing (with 400 f2.Cool when I needed to go longer I used the 1.6 extender (7D Body).   
Logged
Tony Jay
Sr. Member
****
Offline Offline

Posts: 2029


« Reply #3 on: May 02, 2013, 03:08:28 PM »
ReplyReply

Excellent.
I have been waiting for this since, well, ever since they announced the upgrade last year.

Tony Jay
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad