Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Stressful shopping experience at Metabones  (Read 1898 times)
diuser
Newbie
*
Offline Offline

Posts: 22


« on: April 24, 2014, 08:28:27 AM »
ReplyReply

Having read some glowing reviews of Metabone's speedboosters, I ordered a C/Y to M43 version. (399 US$ for the adapter plus 27 US$ for shipping).  A shipping time from Hongkong to South Korea of more than 2 weeks helped building up my anticipation.

Unluckily, this anticipation was seriously disappointed. Instead of providing the promised 1 stop of more light and superior sharpness, the adapter just turned  the monitor on my Olympus E-M5 black.

A short search on Google unearthed a  'black screen issue' that plagues several producers' adapters for Olympus M43 cameras. The lens locking pins on Olympus cameras (unlike their Panasonic brethren) are very sensitive in regard to the depth of the matching recesses on the bayonet rings of the lens adapters. If those recesses (holes) are too shallow the screens and viewfinders of the camera turn black. This is obviously a matter of only 0.2 or 0.3mms.

I thought a seemingly reputable company like Metabones would know about that and take responsibility for a faulty product, offer an apology and a refund or an exchange.  Especially in light of their prices.

I have ordered plenty of photographic accessories in Hongkong and China before. Some of those products have had problems and the shops were not always eager to take back their merchandise. Some employ a technique of tiring out the customer. Demands for exchange are met with endless questions and requests for images and explanations.

Those experiences were nothing in comparison what transpired at Metabones. From April 5 to April 24, I sent them 7 sometimes lengthy emails. I repeatedly explained the problem including the very simple solution (deepen the lens locking pin recess by a tiny fraction), partly with images illustrating the cause of the problem. To no avail.

On the receiving end, i.e. the support of Metabones, there is somebody who has limited English skills and does not know much about the technical side of his business. Or just plays ignorant in order  to get rid of you.  And misunderstands and misunderstands and asks and asks.

In my final email, I blew my top and threatened to launch a complaint with the Hongkong Consumer Council. Only then did I get an offer to exchange the faulty adapter.

My plan had been to order speedboosters for Canon FD  and Rollei lenses too. However miraculous those adapters might be, there will be no more business from me.

If you are planning on ordering any Metabones adapters for Olympus M43 cameras, you better make sure the 'black screen issue' is resolved. That might save you a lot of time and stress and postpone that approaching heart attack.
« Last Edit: April 24, 2014, 08:38:36 AM by diuser » Logged
Telecaster
Sr. Member
****
Offline Offline

Posts: 866



« Reply #1 on: April 24, 2014, 03:15:55 PM »
ReplyReply

Yep, my SpeedBooster behaves similarly on my E-M5 (but not on my E-M1). Even the weight of a particular lens could make a difference between being able to take pics and the black screen. Fortunately for me I bought the SB for use with a Panasonic GX7, which has no issues with it.

At the very least Metabones should have a warning about this on their website.

-Dave-
Logged
diuser
Newbie
*
Offline Offline

Posts: 22


« Reply #2 on: May 13, 2014, 11:57:06 PM »
ReplyReply

To finish that report:

Metabones exchanged the Speedbooster in a timely fashion, but without any explanation or apology.

The new adapter has some play on the camera side and does not fix the camera in a precise rotational position. It continues to black out the screen when it is slightly twisted to the left.

On the lens side, the adapter is much to tight. I put it on a Contax Mirotar which got stuck to such a degree that I had to build a kind of vice with an industrial rubber belt in order to get it off.

As mirror lenses are rather fragile and the Mirotar is quite expensive, this exercise did not improve my level of satisfaction.

The bayonet-rings of the adapter are made of chromium-plated brass. After trying out roughly a dozen of different lenses, a part of the chromium is already gone and there are scratches in the brass.

Both the Speedboosters I had/have were good, optically. Mechanically, they suck.

I have given up on Metabones. I don't have time to enter another lengthy email exchange with an unwilling service department and will try to use the Speedbooster as it is.

Not recommended. For multiple reasons.
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad