Ad
Ad
Ad
Pages: [1]   Bottom of Page
Print
Author Topic: Help! -- LR5 not "find" Epson 7900 on Mac OS  (Read 295 times)
alan a
Full Member
***
Offline Offline

Posts: 101


« on: August 21, 2014, 03:24:25 PM »
ReplyReply

Any assistance that can be provided by the experts in this forum would be greatly appreciated.  I am printing with an Epson 7900 using the up-to-date version of the Mac OS X.  Two weeks ago the 7900 worked fine.  Now, it won't print.  The issue is not that the Epson OS driver can't communicate with the printer.  I can successfully print the nozzle check and check ink levels from the Mac, so the Mac OS and Epson driver can definitely see the Epson 7900 and print to it.  But LR5 either reports the error that it is looking for the printer, or simply doesn't print.  Photoshop won't print either.

The mystery is that everything was fine only two weeks ago.  I don't recall making any changes to the Mac OS system and certainly did not change the drivers on the 7900.  I deleted the printer and reinstalled it within the OS system preferences.  It made no difference. 

Can anyone tell me what causes LR and Photoshop to not see the printer, and be searching for the printer, when the Mac OS and Epson driver sees the printer just fine, and can report on ink levels, print a nozzle check, etc?

One  other question.  When I reinstalled the printer (added it back to the system after deleting the printer) I was given two options -- to install the 7900 using an IP driver or using Bonjour.  I don't recall how the printer and river were originally installed.  Which should I use?

I am also wondering if the IP address might be a problem, and whether I should assign a static address ion the printer, as well as in the router settings?

I also haven't bothered to update the Epson driver or firmware in about two years, due to the negative reports that sometimes accompany the lastest drivers or firmware.  My approach has been if it isn't broken don't mess with it.  Now that it is broken I could download the lastest drivers and reinstall.






Logged
digitaldog
Sr. Member
****
Offline Offline

Posts: 9317



WWW
« Reply #1 on: August 21, 2014, 04:14:25 PM »
ReplyReply

If you haven't done it lately, I'd do the Epson-Apple driver fix hocus pocus which is to delete all instances of Epson printers from System Preferences>Print & Fax.

Then go to /Library/Printers and toss the whole Epson folder.

Toss LFP Remote Panel (IF you are using this utility for your printer).

Then reinstall drivers FROM Epson, never Apple!

When you go back to Print & Fax to add the printer, on 10.X I had to wait almost a minute before the IP version of the printer showed up, whereas the Bonjour one shows up right away. Then add the IP instance of the printer. This is for printers on a network.

Then re-install LFP Remote Panel if you use it with this printer.

If all else fails, hook up a USB cable, if it prints as I suspect it will, it's the damn network.
Logged

Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/
jferrari
Sr. Member
****
Offline Offline

Posts: 306



« Reply #2 on: August 21, 2014, 08:13:25 PM »
ReplyReply

I am also wondering if the IP address might be a problem, and whether I should assign a static address ion the printer, as well as in the router settings?

Yes, assign a static IP address. Otherwise your router/hub/switch will assign an IP address dynamically and your Mac likely won't find it.     - Jim
Logged

No, I don't own one. But I have seen one on TV.
alan a
Full Member
***
Offline Offline

Posts: 101


« Reply #3 on: August 21, 2014, 08:24:06 PM »
ReplyReply

Many thanks to Rodney and Jim.  I assigned a static address, but it did not resolve the problem.  So I will next go through all the steps recommended by Rodney.

One question though.  In addition to not updating the Epson driver (at least not deliberately, unless Apple did it and I didn't notice) -- I also have not updated the firmware in several years.  Should I do that as well?  Some firmware releases have caused problems.  What about the current firmware on the Epson site?
Logged
Pages: [1]   Top of Page
Print
Jump to:  

Ad
Ad
Ad